Back to overview
Downtime

Dashboard functions are limited

Mar 16 at 05:48pm EDT
Affected services
dashboard.slaystudios.org

Resolved
Apr 05 at 10:02pm EDT

We have fixed the server tab

Updated
Mar 28 at 03:29pm EDT

We will begin our repairs on the servers part of the page on Wednesday 4/2/25

Updated
Mar 18 at 11:46pm EDT

We have fixed the primary issue with sign in not working and all pages being broken.

Commits, servers, main page, and ecoverse are still not working properly.

We are working to fix these.

Created
Mar 16 at 05:48pm EDT

Our dashboard is currently limited on functionality and may be broken.